Author Topic: Problem with my registration form  (Read 1438 times)

yzabel

  • Guest
Problem with my registration form
« on: January 05, 2014, 01:07:24 am »
Hello,

I am working on a registration form for my class and i have two issues. The first one is that every time I fill the form and it submit i get these characters under my navigation: > I tried to find the problem but can't see it. (this happen on the change password page and the login page when the information is entered wrong.

 The second issue is when I try to login, I enter the email & password click submit and it try to find http://yzabel.aisites.com/index.php rather than http://yzabel.aisites.com/IMD331/week4b/index.php. If I hit the back arrow, I am logged in and can then proceed to change the password.

Any help with this would be appreciated. attache are my files
here is the link: [url]http://yzabel.aisites.com/IMD331/week4b/index.php

Happy New Year!

Isabelle
« Last Edit: January 05, 2014, 01:11:39 am by yzabel »

erikkross

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 399
    • Personal Blog with Classroom Tutorials
Re: Problem with my registration form
« Reply #1 on: January 05, 2014, 07:29:53 am »
For the first problem I believe that is being caused by your mysqli_connect.php file. On the very first line of code you have an extra > mark:

><?php # Script 16.4 - mysqli_connect.php

Remove that very first mark. I think that should fix it.


For the second problem, it is because of the following line of code in your config.inc.php file.

// Site URL (base for all redirections):
define ('BASE_URL', 'http://yzabel.aisites.com/');

You need to change the BASE_URL to be the URL of the root of your site. So in your case that would be the following:

// Site URL (base for all redirections):
define ('BASE_URL', 'http://yzabel.aisites.com/IMD331/week4b/');
Erikk Ross
The Art Institute of Pittsburgh, Online Division
Web Design and Interactive Media
Full Time Faculty
eross@aii.edu

yzabel

  • Guest
Re: Problem with my registration form
« Reply #2 on: January 05, 2014, 03:09:20 pm »
Thank you so much! It seems to have fix everything~

Isabelle